Commit 835c2a91 authored by Pawel Spychalski (DzikuVx)'s avatar Pawel Spychalski (DzikuVx)
Browse files

Make antigravity available only for 2.2.2 or higher

parent b618a955
......@@ -360,9 +360,9 @@
},
"dependencies": {
"process-nextick-args": {
"version": "1.0.7",
"resolved": "https://registry.npmjs.org/process-nextick-args/-/process-nextick-args-1.0.7.tgz",
"integrity": "sha1-FQ4gt1ZZCtP5EJPyWk8q2L/zC6M="
"version": "2.0.1",
"resolved": "https://registry.npmjs.org/process-nextick-args/-/process-nextick-args-2.0.1.tgz",
"integrity": "sha512-3ouUOpQhtgrbOa17J7+uxOTpITYWaGP7/AhoR3+A+/1e9skrzelGi/dXzEYyvbxubEF6Wn2ypscTKiKJFFn1ag=="
}
}
},
......@@ -2063,11 +2063,11 @@
},
"dependencies": {
"is-glob": {
"version": "3.1.0",
"resolved": "https://registry.npmjs.org/is-glob/-/is-glob-3.1.0.tgz",
"integrity": "sha1-e6WuJCF4BKxwcHuWkiVnSGzD6Eo=",
"version": "4.0.1",
"resolved": "https://registry.npmjs.org/is-glob/-/is-glob-4.0.1.tgz",
"integrity": "sha512-5G0tKtBTFImOqDnLB2hG6Bp2qcKEFduo4tZu9MT/H6NQv/ghhy30o55ufafxJ/LdH79LLs2Kfrn85TLKyA7BUg==",
"requires": {
"is-extglob": "^2.1.0"
"is-extglob": "^2.1.1"
}
}
}
......@@ -3979,7 +3979,7 @@
"semver": "^5.5.0",
"simple-glob": "~0.2.0",
"tar-fs": "^1.13.0",
"temp": "temp@github:adam-lynch/node-temp#279c1350cb7e4f02515d91da9e35d39a40774016",
"temp": "github:adam-lynch/node-temp#remove_tmpdir_dep",
"thenify": "^3.3.0",
"update-notifier": "^2.4.0",
"winresourcer": "^0.9.0"
......@@ -4016,7 +4016,7 @@
},
"temp": {
"version": "github:adam-lynch/node-temp#279c1350cb7e4f02515d91da9e35d39a40774016",
"from": "temp@github:adam-lynch/node-temp#279c1350cb7e4f02515d91da9e35d39a40774016",
"from": "github:adam-lynch/node-temp#remove_tmpdir_dep",
"dev": true,
"requires": {
"rimraf": "~2.2.6"
......@@ -5954,14 +5954,14 @@
}
},
"set-value": {
"version": "0.4.3",
"resolved": "https://registry.npmjs.org/set-value/-/set-value-0.4.3.tgz",
"integrity": "sha1-fbCPnT0i3H945Trzw79GZuzfzPE=",
"version": "2.0.1",
"resolved": "https://registry.npmjs.org/set-value/-/set-value-2.0.1.tgz",
"integrity": "sha512-JxHc1weCN68wRY0fhCoXpyK55m/XPHafOmK4UWD7m2CI14GMcFypt4w/0+NV5f/ZMby2F6S2wwA7fgynh9gWSw==",
"requires": {
"extend-shallow": "^2.0.1",
"is-extendable": "^0.1.1",
"is-plain-object": "^2.0.1",
"to-object-path": "^0.3.0"
"is-plain-object": "^2.0.3",
"split-string": "^3.0.1"
}
}
}
......
......@@ -269,19 +269,19 @@
<div class="helpicon cf_tip" data-i18n_title="itermRelaxTypeHelp"></div>
</td>
</tr>
<tr class="requires-v2_2">
<tr class="requires-v2_2_2">
<th data-i18n="antigravityGain"></th>
<td >
<input class="rate-tpa_input" data-setting="antigravity_gain" />
</td>
</tr>
<tr class="requires-v2_2">
<tr class="requires-v2_2_2">
<th data-i18n="antigravityAccelerator"></th>
<td >
<input class="rate-tpa_input" data-setting="antigravity_accelerator" />
</td>
</tr>
<tr class="requires-v2_2">
<tr class="requires-v2_2_2">
<th data-i18n="antigravityCutoff"></th>
<td >
<input class="rate-tpa_input" data-setting="antigravity_cutoff_lpf_hz" />
......
......@@ -214,6 +214,12 @@ TABS.pid_tuning.initialize = function (callback) {
$('.requires-v2_2').hide();
}
if (semver.gte(CONFIG.flightControllerVersion, "2.2.2")) {
$('.requires-v2_2_2').show();
} else {
$('.requires-v2_2_2').hide();
}
if (semver.lt(CONFIG.flightControllerVersion, "2.2.0")) {
$('[name=ff]').prop('disabled', 'disabled');
}
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment