Verified Commit 4fdfaf53 authored by David Haynes's avatar David Haynes 🙆
Browse files

Add the obnoxious dependecy check to CI

- used to ensure that we are running the latest packages when possible
parent c95d1243
......@@ -43,5 +43,6 @@ whats-open-py3.6:
type: test
script:
- python manage.py test
- if pip list --outdated --format=legacy | grep "Latest" | wc -l > 0; then echo "Please update your dependecies!" && pip list --outdated --format=legacy && exit 1; else exit 0; fi
- coverage run --source=website --omit=*migrations/*,*admin.py,*__init__.py,*.pyc manage.py test
- coverage html -i && grep pc_cov htmlcov/index.html | egrep -o "[0-9]+\%" | awk '{ print "covered " $1;}'
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment