Verified Commit 8ac0c44e authored by Kunal Sarkhel's avatar Kunal Sarkhel
Browse files

Disable pip upgradable package check

The whats-open-py3.6 checks to see if any packages are upgradable and
fails the build if there are. We need to find a better solution for it.
For now, I have disabled it. We can reenable it in the future.
parent 9bd6df09
......@@ -13,7 +13,7 @@ before_script:
- apt-get install -y mysql-client libmysqlclient-dev python-mysqldb libgdal1h libproj-dev proj-data proj-bin
- pip install -r requirements/test.txt
- cd whats-open/
- export WOPEN_SECRET_KEY=$(dd if=/dev/urandom count=100 | tr -dc "A-Za-z0-9" | fold -w 60 | head -n1 2>/dev/null)
- export WOPEN_SECRET_KEY=$(dd if=/dev/urandom count=102 | tr -dc "A-Za-z0-9" | fold -w 60 | head -n1 2>/dev/null)
- export WOPEN_EMAIL_DOMAIN="@masonlive.gmu.edu"
- export WOPEN_DB_NAME="wopen"
- export WOPEN_DB_USER="root"
......@@ -42,6 +42,5 @@ whats-open-py3.6:
image: library/python:3.6
type: test
script:
- if pip list --outdated --format=legacy | grep "Latest" | wc -l > 0; then echo "Please update your dependecies!" && pip list --outdated --format=legacy && exit 1; else exit 0; fi
- coverage run --source=api --omit=*migrations/*,*admin.py,*__init__.py,*.pyc manage.py test
- coverage html -i && grep pc_cov htmlcov/index.html | egrep -o "[0-9]+\%" | awk '{ print "covered " $1;}'
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment