Commit bbb72778 authored by hdeadman's avatar hdeadman

update gradle wrapper config to remove deprecation warning

parent e5e67053
......@@ -76,6 +76,11 @@ bootRun {
classpath = sourceSets.main.runtimeClasspath
}
wrapper {
distributionType = Wrapper.DistributionType.BIN
gradleVersion = "${project.gradleVersion}"
}
dependencies {
if (project.hasProperty("external")) {
compile "org.apereo.cas:cas-server-webapp:${project.casVersion}"
......@@ -120,10 +125,6 @@ task debug(group: "build", description: "Debug the CAS web application in embedd
}
}
task wrapper(type: Wrapper, description: "Update the Gradle wrapper") {
gradleVersion = "${project.gradleVersion}"
}
task casVersion(group: "build", description: "Display the current CAS version") {
doFirst {
println "${project.casVersion}"
......@@ -137,5 +138,10 @@ task showConfiguration(group: "build", description: "Show configurations for eac
}
}
task updateWrapper(description: "Update the Gradle wrapper") {
println "Updating gradle wrapper to version specified in gradle.properties: ${project.gradleVersion}"
dependsOn wrapper
}
task allDependenciesInsight(type: DependencyInsightReportTask, description: "Produce insight information for all dependencies") {}
task allDependencies(type: DependencyReportTask, description: "Display a graph of all project dependencies") {}
......@@ -11,4 +11,4 @@ tomcatFullVersion=9.0.12
sourceCompatibility=10
targetCompatibility=10
gradleVersion=4.10
gradleVersion=4.10.2
distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
distributionUrl=https\://services.gradle.org/distributions/gradle-4.9-bin.zip
distributionUrl=https\://services.gradle.org/distributions/gradle-4.10.2-bin.zip
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment