Commit 98bed2aa authored by David Haynes's avatar David Haynes 🙆
Browse files

Merge branch '131-twoScoops' into '2.2-dev'

adds two scoops style requirements.txt

See merge request !71
parents 0a435aca b373a889
Pipeline #848 passed with stage
in 59 seconds
......@@ -11,7 +11,7 @@ variables:
before_script:
- apt-get update -qy
- apt-get install -y libldap2-dev libsasl2-dev mysql-client libmysqlclient-dev python-mysqldb
- pip install -r requirements.txt
- pip install -r requirements/ci.txt
- cd go/
- cp settings/settings.py.template settings/settings.py
- cp settings/secret.py.template settings/secret.py
......@@ -37,6 +37,5 @@ Go-py3.6:
image: library/python:3.6
type: test
script:
- pip install coverage
- coverage run --source=go --omit=*migrations/* manage.py test
- coverage html -i && grep pc_cov htmlcov/index.html | egrep -o "[0-9]+\%" | awk '{ print "covered " $1;}'
......@@ -8,6 +8,6 @@ RUN apt-get install netcat -y
RUN mkdir /go
WORKDIR /go
ADD requirements.txt /go/
RUN pip install -r requirements.txt
ADD /requirements/ /go/
RUN pip install -r base.txt
ADD . /go/
Django==1.10
django-auth-ldap==1.2.8
django-crispy-forms==1.6.0
django-ratelimit==1.0.1
git+https://github.com/bruno207/django-qrcode.git
flake8==3.0.4
git+https://github.com/kstateome/django-cas.git
git+https://github.com/bruno207/django-bootstrap3-datetimepicker.git
gunicorn==19.6.0
hashids==1.1.0
mccabe==0.5.2
mysqlclient
pep8==1.7.0
Pillow==3.3.0
pyflakes==1.2.3
pyldap
requests==2.11.0
simplejson==3.8.2
wheel==0.29.0
# This file is here because many platforms as a service look for
# requirements.txt in the root directory of a project.
-r requirements/base.txt
Django==1.10
django-auth-ldap==1.2.8
django-crispy-forms==1.6.0
django-ratelimit==1.0.1
git+https://github.com/bruno207/django-qrcode.git
git+https://github.com/kstateome/django-cas.git
git+https://github.com/bruno207/django-bootstrap3-datetimepicker.git
hashids==1.1.0
mysqlclient
pyldap
requests==2.11.0
simplejson==3.8.2
-r base.txt
flake8==3.0.4
pep8==1.7.0
pyflakes==1.2.3
coverage
-r base.txt
flake8==3.0.4
pep8==1.7.0
pyflakes==1.2.3
# Pro-tip: Try not to put anything here. There should be no dependency in
# production that isn't in development.
-r base.txt
gunicorn==19.6.0
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment