Commit eccbed61 authored by David Haynes's avatar David Haynes 🙆

Merge branch '110-dependecies-update' into '2.2-dev'

Resolve "Explore options to update our dependencies"

See merge request !87
parents aa42adb0 70256925
Pipeline #1273 passed with stage
in 2 minutes and 2 seconds
......@@ -56,5 +56,6 @@ Go-py3.6:
image: library/python:3.6
type: test
script:
- if pip list --outdated | grep "Latest" | wc -l > 0; then pip list --outdated && exit 1; else exit 0; fi
- coverage run --source=go --omit=*migrations/*,*admin.py,*manage.py,*wsgi.py,*settings.py,*secret.py,*__init__.py,*.pyc,*templates/*,*static/* manage.py test
- coverage html -i && grep pc_cov htmlcov/index.html | egrep -o "[0-9]+\%" | awk '{ print "covered " $1;}'
Django>=1.11
django-crispy-forms==1.6.1
django-ratelimit==1.0.1
django-redis-cache==1.6.4
django-redis-cache==1.7.1
git+https://github.com/dhaynespls/django-qrcode.git
git+https://github.com/kstateome/django-cas.git
git+https://github.com/dhaynespls/django-bootstrap3-datetimepicker.git
hashids==1.1.0
hashids==1.2.0
mysqlclient
redis==2.10.5
requests==2.11.0
simplejson==3.8.2
requests==2.13.0
simplejson==3.10.0
six
setuptools==35.0.1
\ No newline at end of file
-r base.txt
flake8==3.0.4
flake8==3.3.0
pep8==1.7.0
pyflakes==1.2.3
pyflakes==1.5.0
coverage
django-redis-cache==1.6.4
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment