Commit 511ae95f authored by David Haynes's avatar David Haynes

Update gitlab-ci to use new ci requirements

- also CI >>> ci
parent b79efc41
Pipeline #845 failed with stage
in 27 seconds
......@@ -11,7 +11,7 @@ variables:
before_script:
- apt-get update -qy
- apt-get install -y libldap2-dev libsasl2-dev mysql-client libmysqlclient-dev python-mysqldb
- pip install -r requirements.txt
- pip install -r requirements/ci.txt
- cd go/
- cp settings/settings.py.template settings/settings.py
- cp settings/secret.py.template settings/secret.py
......@@ -37,6 +37,5 @@ Go-py3.6:
image: library/python:3.6
type: test
script:
- pip install coverage
- coverage run --source=go --omit=*migrations/* manage.py test
- coverage html -i && grep pc_cov htmlcov/index.html | egrep -o "[0-9]+\%" | awk '{ print "covered " $1;}'
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment