Commit c1e35622 authored by Daniel W Bond's avatar Daniel W Bond
Browse files

macos merge confictz

parents 168eef3f 1c8a2da3
......@@ -22,6 +22,8 @@ These instructions are for Ubuntu and Debian, or related Linux distributions. (I
First, install python, pip, and git on your system. Python is the programming language used for Django, the web framework used by Roomlist. 'Pip' is the python package manager. Git is the version control system used for SRCT projects.
**Debian/Ubuntu**
Open a terminal and run the following commands.
`sudo apt-get update`
......@@ -32,6 +34,27 @@ This retrieves links to the most up-to-date and secure versions of your packages
you install python and git.
Now you're ready to set up the Roomlist repository on your machine.
**macOS (Formerly OS X)**
This tutorial uses the third party Homebrew package manager for macOS, which allows you to install
packages from your terminal just as easily as you could on a Linux based system. You could use another
package manager (or not use one at all), but Homebrew is highly reccomended.
To get homebrew, run the following command in a terminal:
``/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"`
**Note**: You do NOT need to use `sudo` when running any Homebrew commands, and it likely won't work if you do.
Now you want to Python, pip, git, and MySQL (macOS actually ships with some of these, but we want to have the latest versions). To do so, run the following command in your terminal:
`brew install python git mysql`
Now you're ready to set up the Roomlist repository on your machine.
#### Git Setup
Now, we're going to clone down a copy of the Roomlist codebase from git.gmu.edu, the SRCT code respository.
Configure your ssh keys by following the directions at git.gmu.edu/help/ssh/README.
......
......@@ -8,6 +8,7 @@ django-braces==1.4.0
git+https://github.com/kstateome/django-cas.git
django-crispy-forms==1.4.0
django-filter==0.12.0
git+https://github.com/kstateome/django-cas.git
django-gravatar2==1.1.4
django-haystack==2.3.1
django-localflavor==1.0
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment