Commit 727a3e59 authored by Mattias J Duffy's avatar Mattias J Duffy
Browse files

updated packages and created new map to remove extra names

parent a43e65b5
Pipeline #1858 passed with stage
in 1 minute and 45 seconds
...@@ -130,7 +130,7 @@ class FacilitiesMap extends React.Component { ...@@ -130,7 +130,7 @@ class FacilitiesMap extends React.Component {
}) })
console.log('changed') console.log('changed')
}} }}
style="mapbox://styles/mapbox/streets-v9" style="mapbox://styles/mduffy8/cjbcdxi3v73hp2spiyhxbkjde"
movingMethod={'easeTo'} movingMethod={'easeTo'}
containerStyle={{ containerStyle={{
height: "200px", height: "200px",
...@@ -166,7 +166,7 @@ class FacilitiesMap extends React.Component { ...@@ -166,7 +166,7 @@ class FacilitiesMap extends React.Component {
maxBounds={maxBounds} maxBounds={maxBounds}
zoom={zoom} zoom={zoom}
center={center} center={center}
onRequestClose={this.handleRequestClose} onClose={this.handleRequestClose}
/> />
</div> </div>
) )
......
...@@ -30,7 +30,7 @@ class FacilityDialog extends React.Component { ...@@ -30,7 +30,7 @@ class FacilityDialog extends React.Component {
}; };
render() { render() {
const {facility, facilities, isOpen, onRequestClose} = this.props; const {facility, facilities, isOpen, onClose} = this.props;
const {isMapOpen, maxBounds} = this.state; const {isMapOpen, maxBounds} = this.state;
let mapCenter, mapZoom; let mapCenter, mapZoom;
...@@ -43,8 +43,8 @@ class FacilityDialog extends React.Component { ...@@ -43,8 +43,8 @@ class FacilityDialog extends React.Component {
} }
return ( return (
<Dialog classes={{root: 'fd-dialog-root', paper: 'fd-dialog-paper'}} open={isOpen} onRequestClose={onRequestClose}> <Dialog classes={{root: 'fd-dialog-root', paper: 'fd-dialog-paper'}} open={isOpen} onClose={onClose}>
<IconButton className={'fd-close-btn'} onClick={onRequestClose}> <IconButton className={'fd-close-btn'} onClick={onClose}>
<CloseIcon /> <CloseIcon />
</IconButton> </IconButton>
<Grid container className={'fd-container'} justify={'center'}> <Grid container className={'fd-container'} justify={'center'}>
...@@ -90,7 +90,7 @@ class FacilityDialog extends React.Component { ...@@ -90,7 +90,7 @@ class FacilityDialog extends React.Component {
maxBounds={maxBounds} maxBounds={maxBounds}
zoom={mapZoom} zoom={mapZoom}
center={mapCenter} center={mapCenter}
onRequestClose={this.toggleMap} onClose={this.toggleMap}
/> />
</Dialog> </Dialog>
) )
......
...@@ -36,18 +36,18 @@ const Map = ReactMapboxGl({ ...@@ -36,18 +36,18 @@ const Map = ReactMapboxGl({
class MapDialog extends React.Component { class MapDialog extends React.Component {
handleRequestClose = () => { handleRequestClose = () => {
this.props.onRequestClose(this.props.selectedValue); this.props.onClose(this.props.selectedValue);
}; };
handleListItemClick = value => { handleListItemClick = value => {
this.props.onRequestClose(value); this.props.onClose(value);
}; };
render() { render() {
const { classes, selectedValue,facility,facilities,zoom,center,maxBounds,...other } = this.props; const { classes, selectedValue,facility,facilities,zoom,center,maxBounds,...other } = this.props;
return ( return (
<Dialog onRequestClose={this.handleRequestClose} {...other}> <Dialog onClose={this.handleRequestClose} {...other}>
<Map <Map
onStyleLoad={(map,e)=>{ onStyleLoad={(map,e)=>{
map.addControl(new mapboxgl.GeolocateControl({ map.addControl(new mapboxgl.GeolocateControl({
...@@ -64,7 +64,7 @@ class MapDialog extends React.Component { ...@@ -64,7 +64,7 @@ class MapDialog extends React.Component {
}) })
console.log('changed') console.log('changed')
}} }}
style="mapbox://styles/mapbox/streets-v9" style="mapbox://styles/mduffy8/cjbcdxi3v73hp2spiyhxbkjde"
movingMethod={'easeTo'} movingMethod={'easeTo'}
containerStyle={{ containerStyle={{
height: "500px", height: "500px",
...@@ -95,7 +95,7 @@ class MapDialog extends React.Component { ...@@ -95,7 +95,7 @@ class MapDialog extends React.Component {
MapDialog.propTypes = { MapDialog.propTypes = {
classes: PropTypes.object.isRequired, classes: PropTypes.object.isRequired,
onRequestClose: PropTypes.func, onClose: PropTypes.func,
selectedValue: PropTypes.string, selectedValue: PropTypes.string,
}; };
......
...@@ -88,7 +88,7 @@ class FacilityCard extends React.Component { ...@@ -88,7 +88,7 @@ class FacilityCard extends React.Component {
</Grid> </Grid>
</CardContent> </CardContent>
<FacilityDialog facility={facility} facilities={facilities} isOpen={isSelected} onRequestClose={this.handleCardClick} /> <FacilityDialog facility={facility} facilities={facilities} isOpen={isSelected} onClose={this.handleCardClick} />
</Card> </Card>
) )
} }
......
...@@ -1736,10 +1736,14 @@ core-js@^1.0.0: ...@@ -1736,10 +1736,14 @@ core-js@^1.0.0:
version "1.2.7" version "1.2.7"
resolved "https://registry.yarnpkg.com/core-js/-/core-js-1.2.7.tgz#652294c14651db28fa93bd2d5ff2983a4f08c636" resolved "https://registry.yarnpkg.com/core-js/-/core-js-1.2.7.tgz#652294c14651db28fa93bd2d5ff2983a4f08c636"
core-js@^2.0.0, core-js@^2.4.0, core-js@^2.5.0: core-js@^2.0.0, core-js@^2.5.0:
version "2.5.1" version "2.5.1"
resolved "https://registry.yarnpkg.com/core-js/-/core-js-2.5.1.tgz#ae6874dc66937789b80754ff5428df66819ca50b" resolved "https://registry.yarnpkg.com/core-js/-/core-js-2.5.1.tgz#ae6874dc66937789b80754ff5428df66819ca50b"
core-js@^2.4.0:
version "2.5.3"
resolved "https://registry.yarnpkg.com/core-js/-/core-js-2.5.3.tgz#8acc38345824f16d8365b7c9b4259168e8ed603e"
core-util-is@1.0.2, core-util-is@~1.0.0: core-util-is@1.0.2, core-util-is@~1.0.0:
version "1.0.2" version "1.0.2"
resolved "https://registry.yarnpkg.com/core-util-is/-/core-util-is-1.0.2.tgz#b5fd54220aa2bc5ab57aab7140c940754503c1a7" resolved "https://registry.yarnpkg.com/core-util-is/-/core-util-is-1.0.2.tgz#b5fd54220aa2bc5ab57aab7140c940754503c1a7"
...@@ -3505,8 +3509,8 @@ ignore@^3.2.0: ...@@ -3505,8 +3509,8 @@ ignore@^3.2.0:
resolved "https://registry.yarnpkg.com/ignore/-/ignore-3.3.7.tgz#612289bfb3c220e186a58118618d5be8c1bab021" resolved "https://registry.yarnpkg.com/ignore/-/ignore-3.3.7.tgz#612289bfb3c220e186a58118618d5be8c1bab021"
immutability-helper@^2.3.0: immutability-helper@^2.3.0:
version "2.5.0" version "2.6.2"
resolved "https://registry.yarnpkg.com/immutability-helper/-/immutability-helper-2.5.0.tgz#01ea7204334997c645bdfa7eb22e8b84c970946e" resolved "https://registry.yarnpkg.com/immutability-helper/-/immutability-helper-2.6.2.tgz#0df76cd906518cf81f79caecb4e55d2850a11e2d"
dependencies: dependencies:
invariant "^2.2.0" invariant "^2.2.0"
...@@ -3745,12 +3749,6 @@ is-obj@^1.0.0: ...@@ -3745,12 +3749,6 @@ is-obj@^1.0.0:
version "1.0.1" version "1.0.1"
resolved "https://registry.yarnpkg.com/is-obj/-/is-obj-1.0.1.tgz#3e4729ac1f5fde025cd7d83a896dab9f4f67db0f" resolved "https://registry.yarnpkg.com/is-obj/-/is-obj-1.0.1.tgz#3e4729ac1f5fde025cd7d83a896dab9f4f67db0f"
is-observable@^0.2.0:
version "0.2.0"
resolved "https://registry.yarnpkg.com/is-observable/-/is-observable-0.2.0.tgz#b361311d83c6e5d726cabf5e250b0237106f5ae2"
dependencies:
symbol-observable "^0.2.2"
is-path-cwd@^1.0.0: is-path-cwd@^1.0.0:
version "1.0.0" version "1.0.0"
resolved "https://registry.yarnpkg.com/is-path-cwd/-/is-path-cwd-1.0.0.tgz#d225ec23132e89edd38fda767472e62e65f1106d" resolved "https://registry.yarnpkg.com/is-path-cwd/-/is-path-cwd-1.0.0.tgz#d225ec23132e89edd38fda767472e62e65f1106d"
...@@ -4293,22 +4291,17 @@ jss-compose@^5.0.0: ...@@ -4293,22 +4291,17 @@ jss-compose@^5.0.0:
warning "^3.0.0" warning "^3.0.0"
jss-default-unit@^8.0.0: jss-default-unit@^8.0.0:
version "8.0.0" version "8.0.2"
resolved "https://registry.yarnpkg.com/jss-default-unit/-/jss-default-unit-8.0.0.tgz#a308ead4f587ebe17cc845f9870867400de90910" resolved "https://registry.yarnpkg.com/jss-default-unit/-/jss-default-unit-8.0.2.tgz#cc1e889bae4c0b9419327b314ab1c8e2826890e6"
dependencies:
is-observable "^0.2.0"
jss-expand@^5.0.0: jss-expand@^5.0.0:
version "5.0.0" version "5.1.0"
resolved "https://registry.yarnpkg.com/jss-expand/-/jss-expand-5.0.0.tgz#8eadb782f29ec5f1d285451dd38052d5ac51644a" resolved "https://registry.yarnpkg.com/jss-expand/-/jss-expand-5.1.0.tgz#b1ad74ec18631f34f65a2124fcfceb6400610e3d"
dependencies:
is-observable "^0.2.0"
jss-extend@^6.0.1: jss-extend@^6.0.1:
version "6.0.1" version "6.1.0"
resolved "https://registry.yarnpkg.com/jss-extend/-/jss-extend-6.0.1.tgz#e53430bc92a42e50d036883ccfecfbc4e1199147" resolved "https://registry.yarnpkg.com/jss-extend/-/jss-extend-6.1.0.tgz#85f3d39944018e8f44b322c14fa316068aa7bb0b"
dependencies: dependencies:
is-observable "^0.2.0"
warning "^3.0.0" warning "^3.0.0"
jss-global@^3.0.0: jss-global@^3.0.0:
...@@ -4352,12 +4345,12 @@ jss-vendor-prefixer@^7.0.0: ...@@ -4352,12 +4345,12 @@ jss-vendor-prefixer@^7.0.0:
dependencies: dependencies:
css-vendor "^0.3.8" css-vendor "^0.3.8"
jss@^9.3.1, jss@^9.3.2: jss@^9.3.2, jss@^9.3.3:
version "9.3.3" version "9.4.0"
resolved "https://registry.yarnpkg.com/jss/-/jss-9.3.3.tgz#d535ad8c64f6df9aeadb0219d5153c47493ff1c0" resolved "https://registry.yarnpkg.com/jss/-/jss-9.4.0.tgz#fbfd1a63556c5afd5bfcffd98df3c50eb2614ed3"
dependencies: dependencies:
is-in-browser "^1.1.3" is-in-browser "^1.1.3"
symbol-observable "^1.0.4" symbol-observable "^1.1.0"
warning "^3.0.0" warning "^3.0.0"
jsx-ast-utils@^1.4.0, jsx-ast-utils@^1.4.1: jsx-ast-utils@^1.4.0, jsx-ast-utils@^1.4.1:
...@@ -4688,9 +4681,9 @@ material-ui-icons@^1.0.0-alpha.19: ...@@ -4688,9 +4681,9 @@ material-ui-icons@^1.0.0-alpha.19:
dependencies: dependencies:
recompose "^0.26.0" recompose "^0.26.0"
material-ui@next: material-ui@^1.0.0-beta.24:
version "1.0.0-beta.21" version "1.0.0-beta.24"
resolved "https://registry.yarnpkg.com/material-ui/-/material-ui-1.0.0-beta.21.tgz#3a28fb4dcb27f8d8db19b48c008522389bf39f2d" resolved "https://registry.yarnpkg.com/material-ui/-/material-ui-1.0.0-beta.24.tgz#a51452d0486f88fd7f13ebed869793f298aa800c"
dependencies: dependencies:
babel-runtime "^6.26.0" babel-runtime "^6.26.0"
brcast "^3.0.1" brcast "^3.0.1"
...@@ -4698,15 +4691,14 @@ material-ui@next: ...@@ -4698,15 +4691,14 @@ material-ui@next:
deepmerge "^2.0.1" deepmerge "^2.0.1"
dom-helpers "^3.2.1" dom-helpers "^3.2.1"
hoist-non-react-statics "^2.3.1" hoist-non-react-statics "^2.3.1"
jss "^9.3.1" jss "^9.3.3"
jss-preset-default "^4.0.1" jss-preset-default "^4.0.1"
keycode "^2.1.9" keycode "^2.1.9"
lodash "^4.17.4" lodash "^4.17.4"
normalize-scroll-left "^0.1.2" normalize-scroll-left "^0.1.2"
prop-types "^15.6.0" prop-types "^15.6.0"
react-event-listener "^0.5.1" react-event-listener "^0.5.1"
react-flow-types "0.2.0-beta.3" react-jss "^8.1.0"
react-jss "^8.0.0"
react-popper "^0.7.4" react-popper "^0.7.4"
react-scrollbar-size "^2.0.2" react-scrollbar-size "^2.0.2"
react-transition-group "^2.2.1" react-transition-group "^2.2.1"
...@@ -6046,19 +6038,15 @@ react-error-overlay@^1.0.9: ...@@ -6046,19 +6038,15 @@ react-error-overlay@^1.0.9:
source-map "0.5.6" source-map "0.5.6"
react-event-listener@^0.5.0, react-event-listener@^0.5.1: react-event-listener@^0.5.0, react-event-listener@^0.5.1:
version "0.5.1" version "0.5.2"
resolved "https://registry.yarnpkg.com/react-event-listener/-/react-event-listener-0.5.1.tgz#ba36076e47bc37c5a67ff5ccd4a9ff0f15621040" resolved "https://registry.yarnpkg.com/react-event-listener/-/react-event-listener-0.5.2.tgz#8fe116f8930a4c7fe363c631f56963d7e4ed3d66"
dependencies: dependencies:
babel-runtime "^6.26.0" babel-runtime "^6.26.0"
fbjs "^0.8.16" fbjs "^0.8.16"
prop-types "^15.6.0" prop-types "^15.6.0"
warning "^3.0.0" warning "^3.0.0"
react-flow-types@0.2.0-beta.3: react-jss@^8.1.0:
version "0.2.0-beta.3"
resolved "https://registry.yarnpkg.com/react-flow-types/-/react-flow-types-0.2.0-beta.3.tgz#93e7e3c95a75a1a941de05b9d7287e3ca6871046"
react-jss@^8.0.0:
version "8.1.0" version "8.1.0"
resolved "https://registry.yarnpkg.com/react-jss/-/react-jss-8.1.0.tgz#7eefe3d121d31d5650118fc4f6b119e388cd43ba" resolved "https://registry.yarnpkg.com/react-jss/-/react-jss-8.1.0.tgz#7eefe3d121d31d5650118fc4f6b119e388cd43ba"
dependencies: dependencies:
...@@ -6106,9 +6094,9 @@ react-router-dom@^4.1.2: ...@@ -6106,9 +6094,9 @@ react-router-dom@^4.1.2:
react-router "^4.2.0" react-router "^4.2.0"
warning "^3.0.0" warning "^3.0.0"
react-router-redux@next: react-router-redux@^5.0.0-alpha.9:
version "5.0.0-alpha.8" version "5.0.0-alpha.9"
resolved "https://registry.yarnpkg.com/react-router-redux/-/react-router-redux-5.0.0-alpha.8.tgz#5242c705730b2ac862aff7a8e90f870d0cf45e12" resolved "https://registry.yarnpkg.com/react-router-redux/-/react-router-redux-5.0.0-alpha.9.tgz#825431516e0e6f1fd93b8807f6bd595e23ec3d10"
dependencies: dependencies:
history "^4.7.2" history "^4.7.2"
prop-types "^15.6.0" prop-types "^15.6.0"
...@@ -6354,8 +6342,8 @@ regenerator-runtime@^0.10.0: ...@@ -6354,8 +6342,8 @@ regenerator-runtime@^0.10.0:
resolved "https://registry.yarnpkg.com/regenerator-runtime/-/regenerator-runtime-0.10.5.tgz#336c3efc1220adcedda2c9fab67b5a7955a33658" resolved "https://registry.yarnpkg.com/regenerator-runtime/-/regenerator-runtime-0.10.5.tgz#336c3efc1220adcedda2c9fab67b5a7955a33658"
regenerator-runtime@^0.11.0: regenerator-runtime@^0.11.0:
version "0.11.0" version "0.11.1"
resolved "https://registry.yarnpkg.com/regenerator-runtime/-/regenerator-runtime-0.11.0.tgz#7e54fe5b5ccd5d6624ea6255c3473be090b802e1" resolved "https://registry.yarnpkg.com/regenerator-runtime/-/regenerator-runtime-0.11.1.tgz#be05ad7f9bf7d22e056f9726cee5017fbf19e2e9"
regenerator-transform@^0.10.0: regenerator-transform@^0.10.0:
version "0.10.1" version "0.10.1"
...@@ -7241,14 +7229,14 @@ sw-toolbox@^3.4.0: ...@@ -7241,14 +7229,14 @@ sw-toolbox@^3.4.0:
path-to-regexp "^1.0.1" path-to-regexp "^1.0.1"
serviceworker-cache-polyfill "^4.0.0" serviceworker-cache-polyfill "^4.0.0"
symbol-observable@^0.2.2: symbol-observable@^1.0.3:
version "0.2.4"
resolved "https://registry.yarnpkg.com/symbol-observable/-/symbol-observable-0.2.4.tgz#95a83db26186d6af7e7a18dbd9760a2f86d08f40"
symbol-observable@^1.0.3, symbol-observable@^1.0.4:
version "1.0.4" version "1.0.4"
resolved "https://registry.yarnpkg.com/symbol-observable/-/symbol-observable-1.0.4.tgz#29bf615d4aa7121bdd898b22d4b3f9bc4e2aa03d" resolved "https://registry.yarnpkg.com/symbol-observable/-/symbol-observable-1.0.4.tgz#29bf615d4aa7121bdd898b22d4b3f9bc4e2aa03d"
symbol-observable@^1.0.4, symbol-observable@^1.1.0:
version "1.1.0"
resolved "https://registry.yarnpkg.com/symbol-observable/-/symbol-observable-1.1.0.tgz#5c68fd8d54115d9dfb72a84720549222e8db9b32"
symbol-tree@^3.2.1: symbol-tree@^3.2.1:
version "3.2.2" version "3.2.2"
resolved "https://registry.yarnpkg.com/symbol-tree/-/symbol-tree-3.2.2.tgz#ae27db38f660a7ae2e1c3b7d1bc290819b8519e6" resolved "https://registry.yarnpkg.com/symbol-tree/-/symbol-tree-3.2.2.tgz#ae27db38f660a7ae2e1c3b7d1bc290819b8519e6"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment