Commit 9b7d4eb6 authored by Andrew Hrdy's avatar Andrew Hrdy

Fixed issue with requiring redux dev tools. Closes #29. (Also set 2.1-dev to staging branch).

parent 67ade9f5
Pipeline #2073 passed with stages
in 1 minute and 55 seconds
......@@ -25,7 +25,7 @@ deploy_staging:
name: staging
url: https://whatsopen.gmu.io
only:
- master
- 2.1-dev
deploy_production:
stage: deploy
......@@ -36,4 +36,4 @@ deploy_production:
when: manual
only:
- master
......@@ -7617,6 +7617,11 @@
"sha.js": "2.4.9"
}
},
"phone-formatter": {
"version": "0.0.2",
"resolved": "https://registry.npmjs.org/phone-formatter/-/phone-formatter-0.0.2.tgz",
"integrity": "sha1-82JsfSdIYPAU9w9DqHVmoWsOes4="
},
"pify": {
"version": "2.3.0",
"resolved": "https://registry.npmjs.org/pify/-/pify-2.3.0.tgz",
......
......@@ -20,7 +20,7 @@ const extension = window.__REDUX_DEVTOOLS_EXTENSION__ && window.__REDUX_DEVTOOLS
const isProduction = process.env.NODE_ENV === 'production';
let enhance;
if (isProduction) {
if (isProduction || !extension) {
enhance = compose(applyMiddleware(ReduxThunk, routerMiddleware(history)));
} else {
enhance = compose(applyMiddleware(ReduxThunk, routerMiddleware(history)), extension);
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment